PictureMe and Catalina Warning

PictureMe and PictureMe Pro are NOT Catalina compatible. Apple makes the life of developers hard by their yearly unannounced new versions of Mac OS, with all kinds of changes under the hood that break existing software. We are working on a new version of PictureMe (Version 3.0) which will be Catalina Compatible. We hope to release that soon, but ran into a major issue with tethering. We advise against upgrading to Catalina yet, as new operating systems often create more issues than provide useful new features. Catalina is a good example; if you are already running Mojave, you should feel no rush to install Catalina. You will likely not be impressed with the benefits.

For those interested in the details; Catalina has a new (undocumented) security layer called Background, which basically prohibits talking to USB connected cameras. As this is something new, it could take a while before a solution is found. We apologize for any inconvenience.

 

Leave a Reply

Your email address will not be published. Required fields are marked *